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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Introduction

This document shows is a step by step guide of how to export a stage and lighting
plan from Vectorworks 2017, with the use of spotlight to MA 3D, which then can be
programmed using any MA2 lighting software.
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Exporting the Stage Plan on Vectorworks

Firstly you will need to export your Vectorworks plan as a 3DS file. However this plan
must not include your lighting fixtures as it will export them as part of the model not

as a lighting fixture which you cannot control.

In Vectorworks go to File > Export > Export 3DS (3D only) you will then be shown

this window:

Depending on what you want in your plan depends on what
layers to export. The recommended selection is All Visible
objects on all layers.

The default scale is 1:1 which is what it needs to be set at.
Leave the rest selected as default.

This is then available to save as a 3DS file wherever you
need it.

Export 30S Options

Export
Selected Objects on Active Layer
Al Visible Objects on Active Layer
@ All Visible Objects on All Layers

Export Gualty {Number of Palygons}:
Fewer ] Mere

7} Expart Obiects [ scate. |

[V} Export Wals
[/} Export 3D Symbols
¥ Plugn Objects

{71 Expont Matedals
| Eort Texdures as
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Importing Stage Plan on MA 3D

Now after opening MA 3D go File > Import > Import 3D Model this will open a

separate window called Import.

Within the Import window go File > Import 3D
Model and select the 3DS file you exported
from Vectorworks.

Once you have import the 3DS file you may be
shown a warning message saying the object is
very big. This means that you need to change
the scale within the import window.

grandMa

¥ The preview abject is very big. If this is not your intention try to scale the basing model.

[noname] 1model(s) O texture(s)

To change the scale press the Scale model
button within the Import window while you have
your plan selected. This will bring up the scale
model window. Select 1 Meter in foreign
application is 1 millimeter in MA 3D (x
0.001). This will put it into the right scale to
work with.

Scale Model...

Scale the Model pemanertly, & 9. to comect diferent unts between MA 30 and other modeling tools
B e defauit unt of MA 3D s “meter”)

Current Size of Model ] 21939 4100 x 27823 3500 x 26000.0000

Scale Mode User Defined

§/ User Defined

| 1 Centimeter in foreign application is 1 Meter in MA 3D (x 100.000)
1 Millimeter in foreign spplication is 1 Meter in MA 3D (x 1000.000)
1 Inch in foreign application is 1 Meter in MA 3D (x 39.370)

1 Foot in foreign application is 1 Meter in MA 3D (x 3.281)

1 Meter in foreign application is 1 Centimeter in MA 3D (x0.010)

1 Meter in foreign application is 1 Millimeter in MA 30 (x0.001)

1 Meter in foreign application is 1 Inch in MA 3D (x 0.025)
1 Meter in foreign application is 1 Foot in MA 3D (x 0.305)

Scales Factor [

Size of Model after Scalng m} |

Display Unit

After you have put it into the right scale you need to save it within the import window.
Go to File > Save as. It will automatically direct you into Grand MA program data
which is where it needs to be saved for MA software to recognise it, ensure that it
has saved there. It will now be saved as a .gmamedia file.

Now that it has been saved exit the import window and go back to Main MA 3D
window. Open Media Database Window by pressing F5 or View > Media Database

Window.

Search for your file name within the filter bar, where M Dtbse
Fiter: i

your plan should appear as icon, and now click and
drag the icon onto the stage view. Your Stage plan

should now appear.

2 Network Type: grandMA2 % ve (newshow)  Shows: new show 2016
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Installing MA Spotlight Plugin on Vectorworks

Firstly, you need to ensure that Vectorworks Spotlight Plugin is installed and added
into your workspace options so you can select it. The spotlight plugin is available on

the MA lighting website under Software.

http://www.malighting.com/en/support-downloads/software.html

To add the plugin into your spotlight works space. Go Tools > workspaces > edit

current workspace.

The workspace editor window will appear and the
Export grandMA2 Setup (XML) plugin will be in
Menus tab under Import/Export.

Then you can click and drag into your workspace
Menus where you want it. At this point you can add
a shortcut command if you wanted.

Expont EPSF.
Eon FBX {20 ordy)...

Export High Dymamic Range image

Expan (FC Project
Expon 1GES (30 wy).

(HOR,
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

MA Patch Setup

First, you will need to setup the MA Software. Go to Setup > Patch & fixture
Schedule > Fixture Types. In this window Import each of your Fixture Types
ensuring that they are under the correct fixture number with the correct modes.

Fixture Types

No. LongName I ShortName Manufacturer{ ShortManu ]

1
Dim Generic Ganeric
3 |Source Four LEIS4LL DSF ETC ETC
4 Rohin 1200 LEC R12LEDW1 Robe Rohe
| 5 |SuUpErSharpy SSharpvL Clay Paky Clay P

A Rahin NI ¥ Qnatr RN ¥Em1 Rnrho Rahs

< |
Generic - Dimmer (00)
1 DIM

Notes
[no items]

Diagnosti

Attribute

]lnstancesl

Direct |
Mods ! |
Vector '
Madas) |

.).
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Spotlight Export MA Fixtures Description

Once The Spotlight Plugin is installed and put into your Workspace you can open the
Export MA Fixtures window. There is a useful tutorial which goes through Spotlight
Plugin and how you need to set it up on the MA software however this is a brief
summary of the process.

Export MA Fixtures V2.2 X

Create MA Layers from

@ Fidure Type (OClass Olayer  (OPostion (O Allin Single Layer
Field Selection
| DMX Address Field Fixture 1D Field Channel 1D
| (i [Grena G <]
i~ Fiture Types
Expot?  RotOffsetX RotOffsetY RotOffsetZ Use Focus MA FadureType No Multi Break Source
Light Instr ETC Source 4 LED2LS Cyclight O None
| Light Instr Rabe Robin 1200 LED Wash 0 O Nene
| Light Instr Clay Paky Super Shamy 07 fL - O MNone
| Light Instr Robe Robin DL4X Spat ] ¢ O leo__n}x_a N “
| Light Instr Clay Paky Alpha Spot HPE 1500 O None
| Light Instr Showtec Stage Blinder 8 O b o | O 2 | Hone

i~ Settings
Load Save

Export ... Cancel

Create MA Layers from: These options go through where it exports the information
from. Keep it selected at Fixture Type

Field Selection: These are important options as they decide where MA reads DMX,
Fixture and Channel numbers from the spotlight info from each fixture.

Export: This selects which fixture types are being exported. If they are not checked
it will not export those fixture types.

RotOffsetX...etc: These are used to change the default position of moving fixtures if
required.

Use Focus: If you have used focus information and focus points in Vectorworks this
will enable you to export this information as well.

MA Fixture Type no: These number selections are very important as they need to
correlate to fixture types number on the MA software.

Multi Break Source: This is used if a fixture has more than one address. You can
then selected where you have inputted information for this

Load and Save: These are used to save and load setups for Export MA Fixtures
window.

Online Tutorial: https://www.youtube.com/watch?v=M3L26gNdnkM
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Exporting Fixtures from Vectorworks

Now to export the spotlight information off your plan ensure that each fixture has all
3D positions set, all required data (Address, Channel), Focus points and focus
information for generics, correct DMX modes, within the Vectorworks plan.

To export open Export MA Fixtures window input correct field selection data:
DMX Addresses field > Address.

Fixture ID Field > Channel.

Channel ID > Channel.

Check the relevant fixture types to export. You must export all fixtures at once, you
cannot add as you go!

Set your MA Fixture Type No. to the relevant number.

To Export you will need to save °
the file in the gma2 folder which
you are working from. Within this & ondie

» USBDISK (E) » gma2

New folder

folder there needs to be an il
importexport folder. Create one if | = =
required. ol [t

@ videos '“”f_:k
It will now save within this folder T
as two separate files, a XML _ mose o

¥ Network

document and another as a File.

File neme: | LightExport
Save as type: | All Files (%)

~ Hide Folders Save
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Importing Fixtures on MA

Firstly, to import the file onto the MA software. Ensure you have selected the drive
where you have saved the import within the backup menu.

Open the setup directory by typing into the command line cd editsetup. To see the
command line feedback press yellow button within the command line. Ensure that all
formatting e.g. spacing CAPS are followed and correct.

To import the file type into the command line import “filename” at layers.

Command Line Feedback

[12h2Bm56.1655 : Executing
12h29m17,.666s : Executing “POSITION"
12h26m18.530s : Executing "POSITION"
3085 Executing
Executing
Executing
Executing
Executing
Executing
Executing /setup
Executing editsetup
34,5368 Executing /
13h0Q5m47 Executing
13h19m30.838s Executing editsetup

al

. EditSetup >import “v2" at Iaversl

113h20m53.632s : Executing : Y PR ayers
113h20m53.632s : Import/export folder of object type “Layers" 1s “"importexport".
{13h20m53.650s : 1 object(s) from “v2.xml" 1mported.

The file will now be Imported. To exit the setup directory type cd/.

In MA 3D your lighting fixtures will be in ready for the visualisation and available to
use with The MA software.
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Exporting a Stage and Lighting Plan into MA 3D from Vectorworks

Network Setup for MA 3D

To connect to The MA3D, you will need to change the IP address on MA 3D to be
within the same range as the console/OnPC software. Open the session window by
pressing F6.

Sessions (grandMA?2)
' Invite Enabled ‘.‘ User: guest -‘] Own IP-Address: 127.0.0.1 (SOD-GRANDMA)

Name —[Session ID[State in Session [Streaming Verson | |
jon] 1 Slave 322

I+ Media Database |/ Sessions (grandMA2)

Once in the session window Click Own IP-Address this will open the Network
settings window. You can change the IP address here as required. If you are using

- OnPC on the same computer as MA3D, you will need to use a loopback IP address
127.0.0.x to use it on the same PC. Loop back meaning that it loops back to
applications on the PC rather than over a network. You may have re restart the
applications for these changes to take effect.

Settings - [m] X
Category % Network
MA-Net IP-Address 127.0.0.1 @ Loopback Pseudo-Interface 1

i Note: You must restart the application to use a different ip-address
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orting a Staae and Lighting Plan into MA 3D from Vectorworks

Exporting a ahting

Creating Network Session for MA on PC and MA 3D

First you will need to create a Network session on The MA software. To do this go to
Setup > MA Network Control > Create Session.

The IP Address for the MA b conrd) (onssed A0
software and MA 3D needs to be | Sarfent

in the same range as each other. 5,14,/1,,11:1
However the last number of the E_—:_::_—:_::l
IP address must be different
from each station if using
separate computers/consoles, if
they are the exact same there ;

will be a collision unless both : A
programs aré running on the
same address.

Now add MA 3D to the network.
Go Setup > MA Network
Configuration > 3D > Add. A
select station window will now
open click on the only station
available.

Now under the Session
member tab within the table
right click the box. It will now
say YES and will highlight
green.

MA 3D will now join the MA Network Session.
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